parser

Написать ответ на текущее сообщение

 

 
   команды управления поиском

В морг. :(

moko 18.06 01:54

"Добрые" люди из Debian в какой-то момент заменили версию parser3-cgi_3.4.4-1_amd64.deb на parser3-cgi_3.4.4-1+b1_amd64.deb.

Причем это даже не новая версия (иначе можно было бы явно установить как apt-get install parser3=cgi_3.4.4-1), это "Binary-only non-maintainer upload for amd64; no source changes", с описанием "rebuild with PIE", и именно в ней началось такое поведение.

Обойти проблему (она происходит при закрытии сессии работы с curl, на закрывающей фигурной скобке) не получится. :(

Так что боюсь или искать пакет без "+b1", поиск находит например это, у меня на Debian 9.9 запустилось без ошибки, либо ждать 7 июля, когда выйдет Debian 10 - в нем будет parser3.4.5, в котором такой проблемы нет.

Сама проблема выглядит багом конкретной версии компилятора С++. Похоже мало кто использует свои методы распределения памяти, в clang (альтернативный gcc компилятор) схожий баг.