parser

Написать ответ на текущее сообщение

 

 
   команды управления поиском

а какие версии либ нужньі для из раздела "Скачать"?

AK666 30.01 06:29 / 30.01 06:46

под jessie (gcc-4.9 g++-4.9) ожидаемо:
/parser/parser3_4_6_debian10x64# ./parser3.cgi
./parser3.cgi: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./parser3.cgi)
не хочется компилить :)


ldd:
./parser3.cgi: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./parser3.cgi)
        linux-vdso.so.1 (0x00007ffdeffb8000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f0dbf2d0000)
        libcrypt.so.1 => /lib/x86_64-linux-gnu/libcrypt.so.1 (0x00007f0dbf099000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f0dbee95000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f0dbeb8a000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f0dbe889000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f0dbe673000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f0dbe2c8000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f0dbf801000)
.

strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep CXXABI_
CXXABI_1.3
CXXABI_1.3.1
CXXABI_1.3.2
CXXABI_1.3.3
CXXABI_1.3.4
CXXABI_1.3.5
CXXABI_1.3.6
CXXABI_1.3.7
CXXABI_1.3.8
CXXABI_TM_1
.

apt-cache policy libstdc++6
libstdc++6:
  Installed: 4.9.2-10+deb8u2
  Candidate: 4.9.2-10+deb8u2
при єтом: libstdc++.so.6 -> libstdc++.so.6.0.20